I'm just kind of curious if the community-at-large agrees on what is
"right". Begin religious debate .......... NOW.
The Java naming convention states "The terms get/set must be used where
an attribute is accessed directly". In my opinion, this convention
breaks encapsulation/information hiding because I would need to change
the method name when changing the implementation (from returning a
computed result to returning an attribute, for example). That's why I
almost never use the get prefix in my own code.
Do not post admin requests to the list. They will be ignored.
Webobjects-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden