Mailing Lists: Apple Mailing Lists
Image of Mac OS face in stamp
Re: Webstart native lib not working since 1.6.0_51
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Webstart native lib not working since 1.6.0_51



On Jun 27, 2013, at 4:54 AM, Christof Aenderl <email@hidden> wrote:

> Hi,
>
> since the update to 1.6.0_51 (incl. latest patch) on OS X 10.7 and 10.8 a native library is not working properly in Webstart but in the standalone version of the application.
> I've added the Permissions and Codebase attribute to the jar containing the natives but that does not help.
> Any idea what has changed in 1.6.0_51 that prevents the native to work?
> BTW: How can I show the console for Java 6?

Does the problem reproduce when you run your application in Web Start Java 7 on the Mac or on Windows? Keep in mind that using Java SE 6 for applets or Web Start is completely unsupported.

There have been many security enhancements and new requirements that all .jars and their contents be signed. Is the .jar that contains the native libraries signed the same way as the primary app .jar is?

Regards,
Mike Swingler
Apple Inc.


 _______________________________________________
Do not post admin requests to the list. They will be ignored.
Java-dev mailing list      (email@hidden)
Help/Unsubscribe/Update your Subscription:

This email sent to email@hidden


References: 
 >Webstart native lib not working since 1.6.0_51 (From: Christof Aenderl <email@hidden>)



Visit the Apple Store online or at retail locations.
1-800-MY-APPLE

Contact Apple | Terms of Use | Privacy Policy

Copyright © 2011 Apple Inc. All rights reserved.