Re: NSObjectController HELP
Re: NSObjectController HELP
- Subject: Re: NSObjectController HELP
- From: Christian Brunschen <email@hidden>
- Date: Thu, 3 Jun 2004 10:14:04 +0100
On 3 Jun 2004, at 06:14, Vince Ackerman wrote:
My Model object :
@interface TeleoObj : NSObject
{
NSMutableString * NetStatusUSBBox;
NSMutableString * NetStatusMsgBox;
NSMutableString * NetStatusAinBox;
NSMutableString * AddressEWBox;
BOOL NetWLimitBox;
BOOL LimitEWSwitch;
BOOL LimitNSSwitch;
float NetAnInBox;
float NetPosNSBox;
float NetPosEWBox;
.... }
You've named your instance variables with things starting with initial
capital letters. This is contrary to the naming convention that Apple
advocates, and which Key-Value Coding and Key-Value Observing
*require*.
Instance variables should be named with an initial lower-case letter.
So an instance variable should be named 'foo', *not* 'Foo'. The
accessor methods associated with the 'foo' instance variable should be
named 'foo' and 'setFoo:' respectively.
Apple have a document about naming conventions. The significance of
naming to Cocoa Bindings is also explained in documentation about Cocoa
Bindings, and about Key-Value Coding and Key-Value Observing.
Best wishes,
// Christian Brunschen
_______________________________________________
cocoa-dev mailing list | email@hidden
Help/Unsubscribe/Archives:
http://www.lists.apple.com/mailman/listinfo/cocoa-dev
Do not post admin requests to the list. They will be ignored.