Re: Can't retrieve cookies (closer, but not there yet)
Re: Can't retrieve cookies (closer, but not there yet)
- Subject: Re: Can't retrieve cookies (closer, but not there yet)
- From: Lachlan Deck <email@hidden>
- Date: Wed, 11 Nov 2009 17:28:43 +1100
On 11/11/2009, at 4:52 PM, Jeff Schmitz wrote:
Actually it's method I defined in my custom WOComponent that all my
other WOComponents inherit from.
public Session Session() {
return (Session)super.session();
}
Don't ask me why I capitalized it.
I _do_ understand why you capitalised it prior to java1.5 (many people
used mySession() for such things). But nowadays just do this:
@Override
public Session session() {
return (Session)super.session();
}
That way you won't have two methods available for auto-completion in
your components that do the same thing -- and it's just the right
thing to do, not to mention dumping a non-standard naming convention :).
with regards,
--
Lachlan Deck
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Webobjects-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden