Re: Filemaker 8.5 stored applescript problem
Re: Filemaker 8.5 stored applescript problem
- Subject: Re: Filemaker 8.5 stored applescript problem
- From: Matt Deatherage <email@hidden>
- Date: Tue, 15 May 2007 19:04:19 -0500
On 5/16/07 at 6:22 PM, Tim Mansour <email@hidden> wrote:
> It's more efficient if we don't use the Finder, and we also don't have
> to worry if it's hung or busy. Surely any "readability" issue could be
> easily solved with a comment:
>
>
> tell application "FileMaker Pro"
>
> -- «event rdwrread» is standard additions "read":
> set cell "FileContents" to «event rdwrread» alias theFilePath
>
> end tell
This is true, and this works within FileMaker's spartan AppleScript
dialog box.
However, if you develop your scripts in Script Editor or (my choice)
Script Debugger for easier debugging, you find that the AppleScript
decompiler changes the raw event codes *back* into the "read" and
"write" English words because they match terms in the Standard Additions
dictionary. Therefore, on your next compile and on every subsequent
change, you have to replace the terms with the raw event codes or you
get the compilation errors again.
If you put the terms in a "tell" block that's anything but FileMaker
(and if Finder galls you, try "System Events"), there's no conflict and
you don't have to keep fighting the decompiler.
If you develop only in the big text field that FileMaker provides for
stored AppleScripts, you don't have the problem either, because
FileMaker doesn't compile/decompile the script in that text field before
displaying it - it stores the text and the compiled version for
execution, but never shows you the decompiled version.
But if you use anything that decompiles scripts (you know, color coding,
changing your syntax into AppleScript's preferred syntax, etc.) then you
can't keep raw event codes in place if they match current dictionary
terms. This is why using a terminology or tell block may be much more
convenient for iterative development, IMHO.
--
Matt Deatherage <email@hidden>
GCSF, Incorporated <http://www.macjournals.com>
"The next big thing is the one that makes the last big thing usable."
-- Blake Ross, co-creator of Mozilla Firefox
_______________________________________________
Do not post admin requests to the list. They will be ignored.
AppleScript-Users mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
Archives: http://lists.apple.com/archives/applescript-users
This email sent to email@hidden