Re: old script fails AND BUG in Smile 3.5.2 (build 609)
Re: old script fails AND BUG in Smile 3.5.2 (build 609)
- Subject: Re: old script fails AND BUG in Smile 3.5.2 (build 609)
- From: "email@hidden" <email@hidden>
- Date: Fri, 26 Mar 2010 08:49:55 -0700
You could insert this into your script:
tell application "Finder"
set theKind to class of item (currentItem as text)
if theKind is folder then set theKind to "folder"
end tell
In place of:
set theKind to kind of currentItem
Also, I'd still caution against using index as a variable, it is an appleScript keyword. In general, if your compiler colors a variable differently than the other variables in your script, you should pick a different name for the variable.
HTH,
ES
_______________________________________________
Do not post admin requests to the list. They will be ignored.
AppleScript-Users mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
Archives: http://lists.apple.com/archives/applescript-users
This email sent to email@hidden