NSBrowser: so very, very broken
NSBrowser: so very, very broken
- Subject: NSBrowser: so very, very broken
- From: The Amazing Llama <email@hidden>
- Date: Fri, 24 Jan 2003 00:04:10 -0800
Why are NSBrowser and its component parts so broken?
- it should be named NSBrowserView
- there is no drag and drop support anywhere; implementing it is
ridiculously complicated.
- when NSBrowser creates new columns, it doesn't check - matrixClass to
see what matrix to fill it with.
- when NSMatrix creates new cells, it doesn't check + cellClass to see
what cells to fill it with.
- more understandably, it doesn't check NSBrowser's +cellClass, either.
- when NSBrowserCell is displayed, it doesn't check - title to see what
it's title should be.
- when NSBrowserCell is displayed, it doesn't check - image to see what
it's image should be.
- the naming conventions are ____InIndex and ____InColumn instead of
Cocoa's more standard ____AtIndex and ____For____
- NSBrowser uses its delegate as it's data source, and there is no way
to separate the two, as there is in NSTableView and NSOutlineView
NSBrowser is one of my favorite features of OSX as a User, but now that
I tried to implement one, I can see quite clearly why they're not
everywhere they could be.
Is this just me, or is it the general feeling that these classes are
flawed? I understand that the origins of this class are different than
most of AppKit, but shouldn't it have been simplified a bit by now?
Seth A. Roby The Amazing Llama < mail or AIM me at tallama at mac dot
com>
"Life is like an exploded clown. It's really funny until you figure out
what just happened."
_______________________________________________
cocoa-dev mailing list | email@hidden
Help/Unsubscribe/Archives:
http://www.lists.apple.com/mailman/listinfo/cocoa-dev
Do not post admin requests to the list. They will be ignored.