Re: Name instance variables, methods and parameters.
Re: Name instance variables, methods and parameters.
- Subject: Re: Name instance variables, methods and parameters.
- From: Allan Odgaard <email@hidden>
- Date: Wed, 28 Jan 2004 14:45:34 +0100
On 28. Jan 2004, at 11:45, M. Uli Kusterer wrote:
I've seen people just use a single character as the name for the
parameter
name, but I feel it makes for less readable code.
Well, I'm not really more experienced, but I just name parameters
something like theData, newData or inData. "newData" is what Apple's
accessor-writing script usually gives me.
From:
http://developer.apple.com/documentation/Cocoa/Conceptual/
CodingGuidelines/Articles/NamingMethods.html#//apple_ref/doc/uid/
20001282/BCIBJEFG
Traditionally (in Cocoa), the following keywords and arguments are used
together:
...action:(SEL)aSelector
...alignment:(int)mode
...atIndex:(int)index
...content:(NSRect)aRect
...doubleValue:(double)aDouble
...floatvalue:(float)aFloat
...font:(NSFont *)fontObj
...frame:(NSRect)frameRect
...intValue:(int)anInt
...keyEquivalent:(NSString *)charCode
...length:(int)numBytes
...point:(NSPoint)aPoint
...stringValue:(NSString *)aString
...tag:(int)anInt
...target:(id)anObject
...title:(NSString *)aString
_______________________________________________
cocoa-dev mailing list | email@hidden
Help/Unsubscribe/Archives:
http://www.lists.apple.com/mailman/listinfo/cocoa-dev
Do not post admin requests to the list. They will be ignored.