Re: Accessor method naming (a question)
Re: Accessor method naming (a question)
- Subject: Re: Accessor method naming (a question)
- From: Prachi Gauriar <email@hidden>
- Date: Thu, 9 Jun 2005 18:40:35 -0400
On Jun 9, 2005, at 6:26 PM, Larry Gerndt wrote:
Quoting from Apple's coding guidelines, located at: http://
developer.apple.com/documentation/Cocoa/Conceptual/CodingGuidelines/
index.html
<quote>
"If the attribute is expressed as a verb, the format is:
- (void)setVerbObject:(BOOL)flag;
- (BOOL)verbObject;
For example:
- (void)setShowsAlpha:(BOOL)flag;
- (BOOL)showsAlpha;"
<quote/>
NSView defines "isHidden" and "setHidden". Shouldn't this be
"isHidden" and "setIsHidden"? If not, then Accessorizor won't
work, because if your ivar is name "isHidden", it will produce
"setIsHidden". I guess the question is, how serious a violation of
the coding rules is "setIsHidden" as opposed to "setHidden"?
Directly above the place you quoted:
<quote>
If the attribute is expressed as an adjective, the format is:
- (void)setAdjective:(BOOL)flag;
- (BOOL)isAdjective
For example:
- (void)setEditable:(BOOL)flag;
- (BOOL)isEditable;
</quote>
"Hidden" is an adjective, so this isn't a violation of the coding
guidelines at all.
-Prachi
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Cocoa-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden