Re: loop efficiency & messages
Re: loop efficiency & messages
- Subject: Re: loop efficiency & messages
- From: Todd Blanchard <email@hidden>
- Date: Wed, 23 Mar 2005 19:51:49 -0800
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
I agree that it's a good idea to stick to
conventions, as long as there is something to be gained by doing so. I
just fail to see exactly what that something might be in the case of: -
(int) getCount.
About the same thing to be gained by not doing (in java):
package My.Nifty.SockeT;
class socket // I've decided to make classes lowercase for readability
{
public static final int $sockeTiSopeN = 1; // *I'm using trailing
capitals to mark constants - heh cool (NOT)
public socket() {}
public void OPEN() {...} // methods should be in all caps - then I know
they're MY methods.
public void READINTOBYTEARRAY(StringBuffer buf) {...}
}
I mean, hey, you can figure it out, right? Why should I follow Sun's
stupid naming guidelines? Do ya suppose because maybe coding like this
makes me look like a total idjit who doesn't know the first thing about
Java?
That's how stupid your comment looks to me right now.
On Mar 23, 2005, at 11:17 AM, Will Mason wrote:
Not exactly on topic but getCount is a lousy name for a method in
objective C.
Oh, don't be daft. Naming a getter method in Objecitve-C is no
different from naming a getter method in any other language, and
Java
for instance routinely uses "get" to prefix a getter method. Just
because "get" is discouraged by Apple doesn't mean we should all
run
from it in terror. Frankly, if a method is named getCount or count,
.......
I agree that it's a good idea to stick to
conventions, as long as there is something to be gained by doing so. I
just fail to see exactly what that something might be in the case of: -
(int) getCount.
Take care,
Will
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (Darwin)
iD8DBQFCQjlVhullemWJdQ8RAjvEAKDk1yxOhyyPnycyDkl1vcC9d4dh5QCffabn
1zvuLKTlVkS5lio+aN/Rwjk=
=XILt
-----END PGP SIGNATURE-----
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Cocoa-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden