CoreData Entity attributes vs. Cocoa naming conventions
CoreData Entity attributes vs. Cocoa naming conventions
- Subject: CoreData Entity attributes vs. Cocoa naming conventions
- From: Jim Correia <email@hidden>
- Date: Mon, 7 Nov 2005 14:33:50 -0500
I generally try to follow the Cocoa naming conventions.
http://developer.apple.com/documentation/Cocoa/Conceptual/
CodingGuidelines/Articles/NamingBasics.html#//apple_ref/doc/uid/
20001281-BBCHBFAH
says:
For method names, start with a lowercase letter and capitalize the
first
letter of embedded words. Don’t use prefixes.
fileExistsAtPath:isDirectory:
An exception to this guideline is method names that start with a
well-known acronym, for example, TIFFRepresentation (NSImage).
URLWithString is another example, from NSURL.
If I try to apply this convention to my CoreData entities (for
example, if I have an entity with a URLString attribute) the data
modeler barks at me and says that attribute names must begin with a
lowercase letter.
Obviously this isn't the end of the world, but setUrlString: is
uglier than setURLString:. Is the UI being overzealous, or enforcing
a hard requirement down inside the frameworks? (Or should I just get
over it - as I have had to do - and just give my accessor and
attribute the "ugly" name? :-)
Jim _______________________________________________
Do not post admin requests to the list. They will be ignored.
Cocoa-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden