Re: newbie interface problem
Re: newbie interface problem
- Subject: Re: newbie interface problem
- From: Chris Hanson <email@hidden>
- Date: Wed, 5 Oct 2005 09:11:03 -0700
On Oct 5, 2005, at 8:42 AM, Bob Sabiston wrote:
Thanks very much for clearing that up. Wow, I had no idea that
Cocoa made assumptions about variable names and variable-setting
function names.
Variable and method naming conventions are the foundation (pardon the
pun) of a critical Cocoa feature: Key-value coding. Bindings and
Core Data also build significantly on key-value coding.
That is pretty strange, especially with that lower-case followed by
upper case. It doesn't make much sense. 'setFoo' sets 'foo' by
default? What if there is a variable 'Foo'?
Standard Cocoa coding style says that you won't have a variable named
"Foo". Here are some good references:
* Coding Guidelines (ADC)
<http://developer.apple.com/documentation/Cocoa/Conceptual/
CodingGuidelines/>
* Objective-C Naming Conventions (ADC)
<http://developer.apple.com/documentation/Cocoa/Conceptual/
ObjectiveC/LanguageSummary/chapter_6_section_11.html>
* Cocoa Style for Objective-C: Part I & II (Scott Stevenson)
<http://www.cocoadevcentral.com/articles/000082.php>
<http://www.cocoadevcentral.com/articles/000083.php>
* Cocoa Style (Aaron Hillegass)
<http://aaron.bignerdranch.com/cocoastyle/>
-- Chris
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Cocoa-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden