Re: Re: Unit testing and Xcode integration
Re: Re: Unit testing and Xcode integration
- Subject: Re: Re: Unit testing and Xcode integration
- From: "Christian Moen" <email@hidden>
- Date: Mon, 14 Aug 2006 21:47:21 +0900
On 8/14/06, Chris Hanson <email@hidden> wrote:
On Aug 13, 2006, at 10:46 PM, Christian Moen wrote:
I don't intend for my responses to be perceived as defensive; I tend
to provide a lot of information as background that can sometimes look
more like rationale. I genuinely want to know what would make the
experience of OCUnit within Xcode better from your -- and others'! --
perspective.
"I was more happy with UnitKit" is a useful data point as far as it
goes, since it indicates that there's more work to do on the
integration. However, it doesn't say what specifically you are
unhappy about with OCUnit as included in Xcode. Specific information
about likes and dislikes is critical for coming up with concrete ways
to improve the experience.
This is why I prefer UnitKit to OCUnit:
1) I really like UnitKit's Growl integration which OCUnit doesn't
support, yet. Just building my test bundle and getting a nicely
formatted Growl message out-of-the-box with test results is very very
nice. OCUnit has build failed, which isn't nearly as cool, and you'll
have to go into Build Results to see what failed when something
failed. It works okay, but it's not very elegant, in my opinion.
2) UnitKit's documentation was brilliant and got me started
immediately. Apple's documentation on OCUnit isn't nearly as good,
yet. Their documentation has a disclaimer that the documentation is
prelimiry, but it doesn't seem to have been updated since Xcode 2.1
(2005-06-06). (I haven't read the documentation that Sen:Te ships
with their OCUnit distribution.)
3) I don't like the inconsistency in naming with OCUnit as a package
name and the ST prefix in the classes and macros. If OCUnit is the
package name, I'd expect class names, macros, etc. to also use an OC
prefix. I know a company names Sen:Te made this and gave it away for
free, which is very nice of them, but I still don't think
SenTestingKit isn't a great name for Xcode's "official" unit test
package in filenames. I think such a package should use a clear and
consistent generic name -- in this case, OCUnit.
My views are not new -- I generally agree very much with Mike Zornek
(see http://mikezornek.com/archives/2005/09/27/ocunit_vs_unitkit.php),
but I don't mind adding a description string to each assert, even
though I think this is a bit superfluous since it's typically obvious
from the test's method name.
My two yen...
Christian
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Cocoa-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden