Re: is this badly written code?
Re: is this badly written code?
- Subject: Re: is this badly written code?
- From: Michael Vannorsdel <email@hidden>
- Date: Mon, 14 Apr 2008 21:06:44 -0600
I don't think there's anything wrong combining messages into a chain
when you only need one variable from it. With the well-worded method
names common with Cocoa it's not too hard to see what the chain is
doing. Sometimes having a bunch of placeholder variables on each line
can look more messy and confusing than one line of chained messages.
On Apr 14, 2008, at 8:53 PM, Adam Gerson wrote:
In cocoa its very tempting to write a single line of code like:
NSManagedObject *selectedTreeObject = [[[[[self delegate]
mainWindowController] treeController] selectedObjects]
objectAtIndex:0];
or to flush it out in to individual lines:
NSWindowController *mainWindow = [[self delegate]
mainWindowController];
NSTreeController *treeController = [mainWindow treeController];
NSArray *selectedTreeObjects = [treeController selectedObjects];
NSManagedObject *selectedTreeObject = [selectedTreeObjects
objectAtIndex:0];
I am looking for some guidance on best practices in a situation with a
lot of nested calls like this. If ultimately the only value I care
about is the final one, selectedTreeObject, whats the best way to go
about getting it? I know "best" is a subjective word. Interested to
hear all of your opinions.
_______________________________________________
Cocoa-dev mailing list (email@hidden)
Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden