Re: NSTableView Popup Column issue
Re: NSTableView Popup Column issue
- Subject: Re: NSTableView Popup Column issue
- From: Kyle Sluder <email@hidden>
- Date: Fri, 6 Feb 2009 21:25:50 -0500
On Fri, Feb 6, 2009 at 3:36 PM, Jon C. Munson II <email@hidden> wrote:
> Well, using "selection" didn't work (now that I've had an opportunity to
> test it). It definitely needs to be arrangedObjects (or something similar).
> So, it isn't that.
"Arranged Objects" is plural. "Selected Object" is singular. It
should be apparent why this is not going to work out, and why you're
winding up with the -description representation of an array in your
popup menu. Table views, on the other hand, support multiple
selection, so the bindings for NSTableView are plural: "Selected
Indexes."
Why are you binding "Selected Object" to a collection of objects?
Typically the Cocoa controls automagically set up their selection
bindings when bound to a controller anyway. This is something that I
have not seen documented, but that Apple employees on this list have
confirmed. I know it's true for NSTableColumn.
Also, you are aware that Core Data allows for many-to-many
relationships without intermediary entities (they are not called
"tables"), right? I understand you have attached attributes to this
relationship, and you need an intermediary entity in this case.
Your naming convention is also rather screwy. It looks like
Bastardized Hungarian (aka "Anti-Hungarian Notation", according to
Larry Osterman:
http://blogs.msdn.com/rick_schaut/archive/2004/02/14/73108.aspx ). It
conveys no useful information; in fact, since Cocoa (and KVO in
particular) rely on the dynamic nature of the ObjC runtime, your
prefixes are lying. And of course, they're incorrect, since there's
no such thing as a "table" in Core Data land. I would suggest ending
your prefixing habit now before you confuse yourself when what you
thought was a "tbl" winds up being an "_NSKeyValueObservingEntity" in
the debugger.
--Kyle Sluder
_______________________________________________
Cocoa-dev mailing list (email@hidden)
Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden