Re: Custom NSArrayController - Dynamic Class?
Re: Custom NSArrayController - Dynamic Class?
- Subject: Re: Custom NSArrayController - Dynamic Class?
- From: Quincey Morris <email@hidden>
- Date: Sat, 18 Jul 2009 15:23:41 -0700
On Jul 18, 2009, at 15:07, Kyle Sluder wrote:
I would instead recommend using -setValue:forKey: like this:
[object setValue:[NSNumber numberWithInteger:[[self arrangedObjects]
indexOfObject:object]] forKey:@"index"]
Yes, it's more sensible.
But now that I think about it, the "performSelector" approach has one
*slight* advantage to the developer. If you ever use Xcode's
refactoring to change the name of the property, it will miss the
property name in the string. With @selector, the method name still
doesn't change, but the refactor window does give a warning that it's
not going to change automatically.
Perhaps the best option is option (c): create a IndexedObject abstract
superclass (if there isn't one already) and use 'object.index = ...'
after all.
_______________________________________________
Cocoa-dev mailing list (email@hidden)
Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden