Re: disabling grammar checking
Re: disabling grammar checking
- Subject: Re: disabling grammar checking
- From: Martin Wierschin <email@hidden>
- Date: Mon, 29 Jun 2009 18:57:44 -0700
i'm not happy that the framework is changing the name of my menu
item from "Show SpellingÅ " (as i've specified in IB) to "Show
Spelling and Grammar". is there some way to globally "fix" this? (i
know i can provide my overrides of showGuessPanel: and
validateMenuItem: in specific field editors, etc., but i'm hoping
for something that doesn't require me to provide a custom field
editor only to fix this.)
I think the best solution is to change the menu item's action to a
selector only you know about, eg: "showKensSpellingPanel:". You could
add a category to NSTextView that simply forwards the action to the
normal "showGuessPanel:". Validation wouldn't work though, unless you
want to swizzle the validator method for NSTextView.
Perhaps it would be best to have something higher up the responder
chain exclusively pick up your custom action, say an NSApplication
delegate. That could inspect the first responder and do validation as
necessary.
It's an unfortunately messy thing any way you do it, especially for
such a trifle.
~Martin
_______________________________________________
Cocoa-dev mailing list (email@hidden)
Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden