Re: Regarding MVC design pattern
Re: Regarding MVC design pattern
- Subject: Re: Regarding MVC design pattern
- From: Kyle Sluder <email@hidden>
- Date: Thu, 20 May 2010 09:39:22 -0700
On Thu, May 20, 2010 at 9:27 AM, Dave Keck <email@hidden> wrote:
> I'm not a fan of isInitialized either, but even less enthralled by
> duplicated code. Furthermore, couldn't one make the case that a class
> that's well-fit for subclassing has exactly one technique for setting
> a property (the setter), giving subclasses full control over that
> behavior?
Not saying your concerns are invalid, but the problem isn't so much
with the initialization of the duplicated code than it is with the
timing within the superclass's init method. Not only is the subclass
sensitive to the fact that its -init implementation needs to call
super's designated initializer before it's done any initialization of
its own, but it's also sensitive to the ordering of multiple accessor
calls within super's initializer implementation.
The only code that should wind up duplicated is an assignment and
perhaps a call to -retain or -release.
> We've been over this before so I'll leave it at that.
Agreed.
--Kyle Sluder
_______________________________________________
Cocoa-dev mailing list (email@hidden)
Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden