About an alternative menu choice and toolbar buttons.
About an alternative menu choice and toolbar buttons.
- Subject: About an alternative menu choice and toolbar buttons.
- From: Daryle Walker <email@hidden>
- Date: Sat, 02 Aug 2014 20:07:11 -0400
I’m trying out Cocoa/Objective-C programming with a web-browser app. I have a NSDocument-based app with a WebView in the window. I have added a toolbar with individual buttons for Back and Forward. I then added menu items for those commands, then added ones for stop-loading, reload, and reload-with-cache-purge.
1. I tried that cool combined button for Back and Forward (NSSegmentedControl), but the entire button uses a single action to send and a single status to have. How can I have the two halves have separate actions and enabled/disabled states?
2. I tried individual toolbar buttons (after failing the combined version) for Stop and Reload, but the Stop one never enabled. The menu items versions do work. Is my loading just too quick for the button to enable?
3. I call the command calling reload: “Reload” and the one calling reloadFromOrigin: “Reload Deeply”. Is that a good name? They share the same line, changing when the Option-key is down (Command-R and Command-Option-R). Is that a good idea? I don’t think Safari exposes the cache-clearing version; is there a good reason for that?
When using WebKit stuff for OS X (or iOS) programs, is this list better, or should I use the WebKit-dev list? I think the latter feels more like cross-platform discussion instead of being Apple-platforms-specific.
—
Daryle Walker
Mac, Internet, and Video Game Junkie
darylew AT mac DOT com
_______________________________________________
Cocoa-dev mailing list (email@hidden)
Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden