Re: Swift and parameter names
Re: Swift and parameter names
- Subject: Re: Swift and parameter names
- From: Quincey Morris <email@hidden>
- Date: Mon, 29 Jun 2015 23:06:57 +0000
On Jun 29, 2015, at 15:42 , Rick Mann <email@hidden> wrote:
>
> Here's an example (and this is what I frequently encounter) where requiring parameter names adds nothing but clutter:
>
> let config = WKWebViewConfiguration()
> self.webView = WKWebView(frame: self.webViewContainer.frame, configuration: config);
Please stop. We already know what you think about this (from the last time you complained). This adds nothing. For every anecdotal example like this, there’s another one like this:
> self.webView = WKWebView(frame: rect, configuration: myParams);
where it adds clarification, not clutter.
> If Code Completion worked 100% of the time, and responded in a millisecond […]
Please stop. Code completion is crappy right now. It’s not a design flaw, it just isn’t finished yet. If you can’t handle that, stop using Swift until it’s more polished. Seriously, if it’s going to annoy *you* to the point where you keep annoying *us*, stick with Obj-C for another year.
> Moreover, when you're skimming the code, it looks a bit like […]
Please stop. You can’t acquire the same familiarity with Swift in 2 months that you have with Obj-C over however many years it’s been.
_______________________________________________
Cocoa-dev mailing list (email@hidden)
Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden