Re: Method name starts with "set"
Re: Method name starts with "set"
- Subject: Re: Method name starts with "set"
- From: Quincey Morris <email@hidden>
- Date: Mon, 01 Aug 2016 22:49:10 -0700
- Feedback-id: 167118m:167118agrif8a:167118s-WfSeplBN:SMTPCORP
On Aug 1, 2016, at 22:11 , Trygve Inda <email@hidden> wrote:
>
> Is this a bad idea?
No, it’s harmless. It’s possible that the compiler will report it as a property, but remember that it’s Obj-C and there were no syntactic properties until a mere 9 years ago. For backward compatibility with code back to the 1980s, the compiler isn’t allowed do anything magical with methods you define.
> How is the best way to name something like this?
I’d avoid making it look like a setter, otherwise you risk confusing future human readers of your code. You could maybe call it “limitConcurrencyTo:”.
Alternatively, just make it a property “maximumOperations” or (better, I think) “maximumOperationCount”. The operation queue value is, after all, itself a property, so writing a getter is trivial. You can even call it “maxConcurrentOperationCount” to match the operation queue, since Apple has already gone to the trouble of devising, debating, focus-grouping and end-user-testing the best possible property name already (hasn’t it?).
_______________________________________________
Cocoa-dev mailing list (email@hidden)
Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden