Re: MIDI Clients and Ports names
Re: MIDI Clients and Ports names
- Subject: Re: MIDI Clients and Ports names
- From: Gary Affonso <email@hidden>
- Date: Wed, 14 May 2003 15:36:12 -0700
On 5/14/03 2:47 PM, "Doug Wyatt" <email@hidden> wrote:
>
You can use any names you like, but please do try to choose meaningful
>
ones.
Uh, what's "meaningful"? I'm using the Java API's for my app, here's what I
do:
midiClient = new MIDIClient(new CAFString("KarmaAuditioner Client"), null);
midiInPort = midiClient.inputPortCreate( new CAFString("KarmaAuditioner
input"), midiListener);
midiOutPort = midiClient.outputPortCreate( new CAFString("KarmaAuditioner
Output") );
Seems sort of redundant to put the app name with "input" or "output"
appended to it for the port names. Is a better naming scheme you'd prefer
to see?
- Gary
Server Side Software
5614 8th Ave NE
Seattle, WA 98105
Voice: (206) 525-4786
Fax: (413) 683-2973
Email: email@hidden
_______________________________________________
coreaudio-api mailing list | email@hidden
Help/Unsubscribe/Archives:
http://www.lists.apple.com/mailman/listinfo/coreaudio-api
Do not post admin requests to the list. They will be ignored.