Re: WOImage: Load Any image with certain prefix...
Re: WOImage: Load Any image with certain prefix...
- Subject: Re: WOImage: Load Any image with certain prefix...
- From: Sacha Mallais <email@hidden>
- Date: Thu, 30 Jun 2005 12:31:57 -0700
On Jun 30, 2005, at 12:19 PM, Nathan Walker wrote:
Efficiency question: If I call this 5-6 times throughout every
page in my application, would that create a performance hit having
to loop through the loop so many times and having to hit "listFiles
()" each time. Does that even matter ? or should be concerned with ?
My usual optimization advice is: optimize the areas you _know_ are a
problem. Spending brain cycles on something that may or may not be a
problem is a waste. In general, unless it is being called thousands
of times, you don't need to worry about it.
Would it be best to create a variable once in the Application class
for File[] fileList = aDirectory.listFiles(); so that only needs
to be called once and reference that variable in the utility method ?
Might be a good idea. Remember that this is a space-for-speed trade-
off and that now you'll have to worry about data freshness.
sacha
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Webobjects-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden