Re: binding oddity?
Re: binding oddity?
- Subject: Re: binding oddity?
- From: Michael Gargano <email@hidden>
- Date: Wed, 03 Nov 2010 08:58:20 -0400
I did, I was just wondering how that worked it's way in to the resolution process. I know that's a typical Apple naming convention, but I don't recall this happening with Cocoa KVC. Is this WO specific?
-Mike On Nov 3, 2010, at 4:36 AM, Stefan Klein wrote:
Hi Mike,
there is also an isBindig or _isBinding for boolean values.
In your case, you mixed up anObject an isAnObject().
Rename the method boolean isAnObject() and it should work.
Stefan
Am 03.11.10 07:47, schrieb Michael Gargano:
I made a component yesterday that looked like this...
public class myComp extends ERXComponent {
public SomeEntity anObject;
}
anObject was bound in the wod and everything worked great. Later I added a method...
public class myComp extends ERXComponent {
public SomeEntity anObject;
public boolean isAnObject() {
return false;
}
}
this is where all hell broke lose. As soon as I added that method I kept getting KVC errors stating that no such key "anObject" existed on a binding that was just working. Can anyone explain this to me? I thought the search order was getBinding(), binding(), _getBinding(), _binding(), binding, _binding.
Does isBinding() squeeze into that ordering somewhere?
Is this a special case for binding to any boolean?
Thanks.
-Mike
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Webobjects-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden
|
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Webobjects-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden