Re: [ANN] Xcode + Leopard at WWDC this year
Re: [ANN] Xcode + Leopard at WWDC this year
- Subject: Re: [ANN] Xcode + Leopard at WWDC this year
- From: JongAm Park <email@hidden>
- Date: Wed, 19 Jul 2006 19:22:30 -0700
Thank you for asking this issue.
Although I am a casual Mac OS X programmer at home, it will be very nice
to hear that the Xcode is improved.
The improvement I want is :
- local / auto / watch variable viewer in one location like that of
the Eclipse and the Visual C++
Although the variable viewer of the Xcode is improved with its
latest version, but it still waste of its screen real estate assigned
for the variable viewer for classes.
Also, separate "expression" window is somewhat cumbersome.
- find in project / folders
The regular expression, ^, doesn't seem to be recognized. It means
the first position of a line. I reported this problem before, but I
still don't see that this is fixed.
Also, it would be good if there is 'find in folders". ( Is there
already? I don't have a Mac in front of me right now. )
- more refined menu / contextual menu
- Edit / Debug / Build pane
Why?????????
You are going to be concentrate on one case. So, opening separate
pane for them makes the screen messy, IMHO. Can't the Edit pane be a
Debug pane just like the Visual C++ IDE or the Eclipse? (Because some
will prefer current approach, it would be good if it can be
user-configurable.)
- new icons for differentiating private method and public method.
Well, there is no private and public method. However, if you
implement a method in *.m file only, it becomes a private method.
Wouldn't it be nicer if there is a different icon or class visualizer
for that?
- Makefile viewer
Eclipse can parse the Makefile and display it on a separate pane. It
is very nice to analyze a makefile.
- Makefile <=> Xcode project converter
- configure <=> Xcode project converter (optionally)
- Categorized Code Sense?
Wouldn't it be nicer if the completion list shows that what parent
class has the methods on the list?
It would be also nice to sort the list in the order, "direct
parent class", "parent class of the direct parent class" ....
- smaller icons for debug related buttons like "step into", "step over"
It would be also nice if users can reposition the button strip. It
is nice to have vertical strip of debug buttons, and positioned on one
side of an editor window.
- multiple line of messages
Some messages like build error are too long for being displayed on
one line. Can't it be multiple line? ( Yeah.. you can make the column
wider, but sometimes it is still not wide enough. You can't make it
wider than your screen width. )
- allowing different code style.
For example, current editor inserts code blocks like :
if( ) {
...
}
However I prefer :
if()
{
...
}
, because it is easier to read and analyze codes in long and messy
code.
There are so many things, so I can't write all of those here!
Thank you.
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Xcode-users mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden