invalid conversion from void* to void**
invalid conversion from void* to void**
- Subject: invalid conversion from void* to void**
- From: Alfred Van Hoek <email@hidden>
- Date: Fri, 6 Oct 2006 23:58:16 -0400
Might be trivial, but what used to compile does not anymore:
Given:
IOFireWireAVCLibUnitInterface** avcUnit;
// ask for the AVC unit interface result = (*interface)->QueryInterface( interface, CFUUIDGetUUIDBytes( kIOFireWireAVCLibUnitInterfaceID ), (LPVOID)&avcUnit );
The compiler chokes on (LPVOID)&avcUnit. This is how it should be called though, (LPVoid)avcUnit will lead to a crash. Any pointers?
Allfred |
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Xcode-users mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden