Re: -Wall
Re: -Wall
- Subject: Re: -Wall
- From: Stefan Werner <email@hidden>
- Date: Wed, 4 Jun 2008 17:38:23 -0700
On Jun 4, 2008, at 5:15 PM, Stuart Malin wrote:
Is there some other way I can inform the compiler (and a future
maintainer) that the parameter is intentionally not used?
I'm not sure how it works for Objective-C, but in C and C++ you tell
gcc that a parameter is unused by not naming it. Instead of:
int foo (int parmUsed, bool parmUnused)
{
return parmUsed+1;
}
write
int foo (int parmUsed, bool)
{
return parmUsed+1;
}
-Stefan
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Xcode-users mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden
- Follow-Ups:
- Re: -Wall
- From: Jean-Daniel Dupas <email@hidden>
- Re: -Wall
- From: Stuart Malin <email@hidden>
References: | |
| >-Wall (From: Stuart Malin <email@hidden>) |
| >Re: -Wall (From: "Sean McBride" <email@hidden>) |
| >Re: -Wall (From: Stuart Malin <email@hidden>) |