Re: Release understanding help…
Re: Release understanding help…
- Subject: Re: Release understanding help…
- From: j o a r <email@hidden>
- Date: Tue, 7 Dec 2004 21:56:04 +0100
On 2004-12-07, at 19.25, Thomas Davie wrote:
I don't see why stringWithFormat is considered to be better than
stringByAppendingString...
Only because I did in one line what you did in two. Just a little bit
more readable (IMO), nothing more.
[NSString stringWithFormat:@"0123456789mc/\" %@", [[NSUserDefaults
standardUserDefaults] objectForKey:NSDecimalSeparator];
and
[@"0123456789mc/\" " stringByAppendingString:[[NSUserDefaults
standardUserDefaults] objectForKey];
are pretty much as readable as each other. In fact the second one
could be considered clearer because the reader doesn't have to scan
along the string to find the %@. They are equally efficient (they both
have to create and free two string objects). Is there a reason to
chose one over the other... Other than that the second is more
readable.
That was my only point. And I agree, in the end the result would be the
same - and it's of course also subject to personal preference.
It might even be better to append the string, as you would avoid the
pitfalls of having to think about what you pass as a format string
(it's bad if it contains unexpected "%" characters...).
I consider readability (and hence maintainability) to be very
important, and something to really try to strive for - so it's worth
thinking about.
j o a r
Attachment:
smime.p7s
Description: S/MIME cryptographic signature
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Cocoa-dev mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden