Re: bus count and channel info confusion
Re: bus count and channel info confusion
- Subject: Re: bus count and channel info confusion
- From: Stefan Gretscher <email@hidden>
- Date: Fri, 16 Jul 2004 18:25:55 +0200
Frank Hoffmann:
I found many plug-ins that feature a single stereo out but have a
output bus count of 2.
Marc Poirier:
That's definitely incorrect. That's mixing up channels and busses.
Am 16.07.2004 um 11:59 schrieb Urs Heckmann:
except for hundreds of AUs that report multiple Bus Counts when they
can only handle a single one
We've had the same bug with our AUs, because we didn't initialize the
AU base classes properly.
(and thanks again Frank for pointing this problem out to us!)
I could very well imagine many other AU developers made the same
mistake, due to a somewhat
misleading naming in the SDK in AUBase.h (and similar in
MusicDeviceBase.h):
/*! @ctor AUBase */
AUBase(AudioUnit inInstance,
UInt32 numInputs,
UInt32 numOutputs,
UInt32 numGroups = 0);
We first put in the (maximum) number of inputs and outputs, but in fact
it's the number of elements
(=busses), so for a simple stereo synth we used
MusicDeviceBase(mAUnit, 0,2) where using
MusicDeviceBase(mAUnit, 0,1) would have been correct.
So if anybody else is wondering why their AUs have an unexpected number
of busses, that's where
to look first. To avoid this confusion in the future, I suggest the
constructor parameter names for
AUBase and MusicDeviceBase should be changed to something like
/*! @ctor AUBase */
AUBase(AudioUnit inInstance,
UInt32 numInBusses,
UInt32 numOutBusses,
UInt32 numGroups = 0);
Kind regards,
Stefan Gretscher
_______________________________________________
coreaudio-api mailing list | email@hidden
Help/Unsubscribe/Archives:
http://www.lists.apple.com/mailman/listinfo/coreaudio-api
Do not post admin requests to the list. They will be ignored.