ld: warning: can't add line info to anonymous symbol
ld: warning: can't add line info to anonymous symbol
- Subject: ld: warning: can't add line info to anonymous symbol
- From: Jack Howarth <email@hidden>
- Date: Wed, 4 Aug 2010 11:55:51 -0400
Is there any documentation on the "ld: warning: can't add line info to anonymous symbol"
warning from the linker in Xcode 3.2.3? The FSF gcc developers have proposed changes
to clean up i386 prologue/epilogue generation which now trigger this warning at -m32
on x86_64-apple-darwin10 for 160+ libstdc++ testcases. The warnings appear as...
/usr/bin/ld -dynamic -arch i386 -macosx_version_min 10.6.4 -weak_reference_mismatches non-weak -v -o ./39882.exe -lcrt1.10.5.o -L/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/x86_64-apple-darwin10.4.0/i386/libstdc++-v3/src -L/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/x86_64-apple-darwin10.4.0/i386/libstdc++-v3/src/.libs -L/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/./gcc/i386 -L/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/./gcc -L/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/x86_64-apple-darwin10.4.0/i386/libstdc++-v3/src/.libs 39882.o ./libtestc++.a -lm -lstdc++ -lgcc_s.10.5 -lgcc_ext.10.5 -lgcc -no_compact_unwind -lSystem
@(#)PROGRAM:ld PROJECT:ld64-97.14
Library search paths:
/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/x86_64-apple-darwin10.4.0/i386/libstdc++-v3/src
/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/x86_64-apple-darwin10.4.0/i386/libstdc++-v3/src/.libs
/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/./gcc/i386
/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/./gcc
/sw/src/fink.build/gcc46-4.6.0-1000/darwin_objdir/x86_64-apple-darwin10.4.0/i386/libstdc++-v3/src/.libs
/usr/lib
/usr/local/lib
Framework search paths:
/Library/Frameworks/
/System/Library/Frameworks/
ld: warning: can't add line info to anonymous symbol initializer$0 from 39882.o
FYI, the changes are roughly described as...
-----------------------------------------------------------------------------------------
I've been preparing the i386 backend to add Win64 SEH unwind info.
At first ktietz and I believed that RBP *must* point below the
register save area (instead of at the top like the traditional
frame pointer), but that turned out to be a bit of confusion in
the reading of the spec and noticing that MSVC *does* point RBP
below the register save area.
In preparation for this movement of the frame pointer, I noticed
how convoluted this prologue/epilogue code is, and how decentralized
the knowledge is.
This patch series cleans up the generation so that much more of the
knowledge of frame layout is centralized in ix86_compute_frame_layout.
Sequential conditions (e.g. where to save the registers) that must
be mutually exclusive are changed to use boolean variables instead
of replicating complicated conditions.
The result is, I think, significantly more readable.
Tested on x86_64-linux. There are no code generation changes within
x86_64 cc1 after the patch series. Final testing on i686-linux is
yet to complete; I'll check on that tomorrow morning.
r~
Richard Henderson (9):
Eliminate most of the conditional compilation from dwarf2out.c.
Simplify logic saving the int registers in the prologue.
Consolidate red-zone logic into ix86_using_red_zone.
Cleanup 32-bit ms_hook code.
Remove duplicate definition of TARGET_64BIT_MS_ABI.
Emit the prologue/epilogue using frame offsets.
Describe unwinding for realigned frames explicitly.
Remove code duplication in ix86_expand_epilogue.
Force the use of stack_pointer_offset in computing the frame size.
------------------------------------------------------------------------------------------
_______________________________________________
Do not post admin requests to the list. They will be ignored.
Xcode-users mailing list (email@hidden)
Help/Unsubscribe/Update your Subscription:
This email sent to email@hidden